Страница 1 из 1

Cisco Nat load balancing + VRF

Добавлено: 27 сен 2019 12:44
Павел Кротов(PavelPP)
Здравствуйте, Уважаемые эксперты.

Все мы прекрасно знаем про возможность организации простой балансировки tcp сессий средствами NAT Destanation на роутере Cisco.
https://habr.com/ru/post/108978/
http://www.anticisco.ru/blogs/2010/11/n ... 2%D1%8C-2/

Но вот потребовалось "Cisco Nat load balancing" настроить на VRF, и оказывается, что нет параметра VRF в командах ip nat inside destination...
Как же заставить работать работать Cisco Nat load balancing + VRF вместе?

ip access-list extended CISCO-NAT-LB
permit tcp any host 5.5.5.5 eq 443 4441 4442 <-Внешние IP

ip nat pool CISCO-NAT-LB 10.1.1.1 10.1.1.2 netmask 255.255.255.0 type rotary <-Внутреннние IP серверов, на кого балансировать.
ip nat inside destination list CISCO-NAT-LB pool CISCO-NAT-LB

interface GigabitEthernet0/0.22
ip vrf forwarding VRF1
ip nat outside
ip address 172.1.1.2 255.255.255.0

interface GigabitEthernet0/0.23
ip vrf forwarding VRF1
ip nat inside
ip address 172.1.2.2 255.255.255.0